All Systems Operational

About This Site

Better Impact provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us at support@betterimpact.com

Web Application ? Operational
Url Shortener ? Operational
Email Delivery Operational
SMS Message Delivery Operational
Other ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Web Server Response Time
79 ms
Created with Highcharts 10.3.118:0020:0022:0022. Jan02:0004:0006:0008:0010:0012:0014:0016:0001k2k3k
Real User Apdex
Fetching
Real User Page Load Time
Fetching
Past Incidents
Jan 22, 2025

No incidents reported today.

Jan 21, 2025

No incidents reported.

Jan 20, 2025

No incidents reported.

Jan 19, 2025

No incidents reported.

Jan 18, 2025

No incidents reported.

Jan 17, 2025
Completed - The scheduled maintenance has been completed.
Jan 17, 23:00 EST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Jan 17, 22:00 EST
Scheduled - We will be performing server maintenance - during this period the myImpactPage.com and admin.betterimpact.com portals will be unavailable for approximately 15-20 minutes.

This maintenance will begin at the following local times:

New York, USA: Friday, January 17, 2025 10:00 PM
London, UK: Saturday, 18 January 2025 3:00 AM
Sydney, Australia: Saturday, 18 January 2025 2:00 PM

Jan 14, 10:24 EST
Jan 16, 2025

No incidents reported.

Jan 15, 2025

No incidents reported.

Jan 14, 2025

No incidents reported.

Jan 13, 2025

No incidents reported.

Jan 12, 2025

No incidents reported.

Jan 11, 2025

No incidents reported.

Jan 10, 2025

No incidents reported.

Jan 9, 2025

No incidents reported.

Jan 8, 2025

No incidents reported.